WordPress 3.3 & Popup Domination 2.0 Problem

Hey Folks!

I’ve been using Popup Domination 2.0 for a while now on a few of my blogs and it has increased the opt-ins dramatically. Last week while updating these to WordPress 3.3 it caused me a bit of a problem and a bit of a headache with Version 2.0 taking the site down and coming up with the following error:

Fatal error: Call to undefined function is_rtl() in /public_html/wp-includes/general-template.php

Easy fix is to go into your FTP and rename the Plugin – However, you lose the plugin. Not Good.

Now, if you’ve already bought Pop up Domination 2.0 and you want to tweak the code to make it work with WP 3.3 read on… OR if you want to do what the developers advise you to do and buy the new retail version of Popup Domination 3.0 at full price, you can do that too – totally up to you:)

By the way, If you haven’t got this Plugin yet – Just buy it, it’s the fastest way to get subscribers on your list, it looks great and it integrates seamlessly with Aweber, Mailchimp, Get Response etc.

OK, Ready for a bit of code cracking? Let’s go.

You can either do this in your cPanel / FTP or even simpler through your WordPress dashboard – let me show you both ways:

In FTP / cPanel navigate to WP-Content > Plugins > Popup-Domination > popup-domination.php (this is the file we’re going to edit)

In Dashboard navigate to Dashboard > Plugins > Editor > Popup Domination (top right dropdown & select) > popup-domination.php (this is the file we’re going to edit)

OK, now were in there search for the following code:

wp_admin_css( 'theme-editor' );

and simply replace it with:

// wp_admin_css( 'theme-editor' );

Yep, that’s it, comment it out:) and hit “update” – you should find this works like a dream.

Have a great day folks! :)